
Procedure for Installation Quality Assurance check of RESRAD-OFFSITE 4.0 

Introduction: The basic installation quality assurance check can be used to verify the installation of the 
commonly used components of RESRAD-OFFSITE.  

The comprehensive installation quality assurance check verifies the installation of all the components of 
the code. 

Installation quality assurance files: The “RESRAD OFFSITE 4.0 Installation QA Files.zip” file, available at 
the user center in the RESRAD website, http://resrad.evs.anl.gov/user-center/, contains the files 
necessary to perform the comprehensive installation quality assurance check. Extract the files and folder 
contained in the QAFiles folder of the zip file, into the QAFiles subdirectory of the RESRAD-OFFSITE 
directory. The input files in the QAFiles folder of the zip file are not read only, to allow them to be 
processed by the code. The QAFiles folder in the zip file also contains a folder named 
QAoutputforComparison. The QAoutputforComparison folder contains 28 files, all are read only file to 
prevent accidental overwriting. These should be placed in the QAFiles\QAoutputforComparison 
subdirectory of the RESRAD-OFFSITE directory. These output files were produced by the code 
developers by running on the release version of the code, the same input files that you copied to the 
QAFiles directory. These input and output files can be used to verify the proper installation and 
functioning of almost all the components of RESRAD-OFFSITE according to the procedure outlined 
below. 

Performing the basic installation quality assurance check:  

Checking the installation of the main interface, main computational code, data and support files, 
deterministic graphic data processing code: 

1. Launch RESRAD-OFFSITE, click ok in the about window. 
2. Open the input file BASIC RESRAD-OFFSITE INSTALLATION QA.ROF from the \QAFiles sub-

directory. (Not the input file with the same name in \QAFiles\QAoutputforComparison.) 
3. Run RESRAD-OFFSITE using that input file. 
4. When RESRAD-OFFSITE has finished processing the input file, it will open the Text Report Viewer 

and will display the parent dose report (named Summary.rep). Click on the file menu on the 
report viewer (not the File menu in the RESRAD-OFFSITE interface) and then click on Save All. 
This saves all the output files to the \QAFiles sub-directory. 

5. Compare a selection of the output files that you just saved to the \QAFiles sub-directory with 
the output files produced by the code developers, which are in the 
\QAFiles\QAoutputforComparison sub-directory. 

a. The deterministic graphics data files with the extension “.grp” in the two directories 
contain the dose, risk and concentrations at each computation time, these are the 
numbers that are used to produce the deterministic graphs in RESRAD-OFFSITE. These 
files are best compared in a spread sheet; this requires knowledge of how to open these 
space delimited (or space separated) ASCII files in your preferred spread sheet program. 
The files may also be compared using file comparison software.  

http://resrad.evs.anl.gov/user-center/


There are advantages to comparing the “grp” files instead of the text report files 
described in the next item.  

i. There is only a single entry of the date and the time of execution at the 
beginning of the file, not once on every page as in the case of the text files.  

ii. The dose, risk and concentration can all be compared in a single file.  
iii. These quantities can be compared at each computation time, not just at the few 

(up to 10) reporting times that were specified in the input file. 
b. The text report files with the extensions “.par” in the two directories contain a listing of 

the input that were used and also a summary of the dose at the up to ten reporting 
times specified in the input file.  
The text report files with the extension “.pro” in the two directories contain the dose at 
the up to ten reporting times specified in the input file. The dose in this case is 
attributed to the radionuclides at the location of exposure, both the initially present and 
the progeny that were produced by radiological transformations. The report with the 
“.par” extension attributes the dose of any transformation products back to the initially 
present parent whose transformations produced the progeny radionuclide.  
The text files with the extension “.rsk” in the two directories contain the excess cancer 
risk at the up to ten reporting times specified in the input file.  
These text report files can be compared in a word processor or in any file comparison 
software. Although the doses, risks and inputs are expected to be the same, the run 
time and date which are output on the first few lines of each page will be different. The 
execution time (or run time) will also likely be different. 

Performing the comprehensive installation quality assurance check:  

Checking the installation of the help files: 
1. Launch RESRAD-OFFSITE, click ok in the about window. 
2. Press the “F1” function short cut key to launch help. 
3. Click on one of the items under contents on the left panel of the help window, help for that item 

will be displayed in the right panel. 
4. Close the help file. 
5. Press the “F3” function key. The User’s Guide will be displayed if Adobe Acrobat or another 

program that is capable of displaying a pdf file is installed on the computer.  
6. Press the “F4” function key. The User’s Manual will be displayed if Adobe Acrobat or another 

program that is capable of displaying a pdf file is installed on the computer. 
7. Close the manual and the guide.  
8. Exit RESRAD-OFFSITE or continue with the check on the installation of the DCF Editor. 

Checking the installation of the DCF Editor and the two dose factor database files: 
1. Launch RESRAD-OFFSITE, click ok in the about window. 
2. Use the “File” menu command and the “DCF Editor” submenu command in RESRAD-OFFSITE to 

launch the DCF Editor.  
3. Click on the ICRP107 option in the Transformation chain database frame.  



4. View a Default Library.  
5. View another default library after clicking the ICRP38 option in the Transformation chain 

database frame.  
6. Exit the DCF Editor. 
7. Exit RESRAD-OFFSITE. 

Checking the installation of the main interface, main computational code, data and support files, 
deterministic graphic data processing code, deterministic and sensitivity graphics viewer, probabilistic 
sampling code, regression analysis code and the probabilistic temporal graphics processing code: 

1. Obtain the RESRAD OFFSITE 4.0 Installation QA Files.zip file from the Users center of the 
RESRAD webpage, http://resrad.evs.anl.gov/user-center/.  

2. Extract the QA input files that you can run and the input files and output files that you will 
compare your output against, from the zip file folders into the corresponding subdirectories of 
the RESRAD-OFFSITE directory as described in installation quality assurance files above. 

3. Launch RESRAD-OFFSITE, click ok in the about window. 
4. Open the input file “COMPREHENSIVE RESRAD-OFFSITE INSTALLATION QA.ROF” from the 

\QAFiles sub-directory. (Not the ‘read only’ input file which is in 
\QAFiles\QAoutputforComparison.) 

5. Run RESRAD-OFFSITE using that input file. 
6. When RESRAD-OFFSITE has finished processing the input file, it will open the Text Report Viewer 

and will display the parent dose report (named Summary.rep). Exit the text report viewer. 
7. Compare a selection of the output files that you just saved to the \QAFiles sub-directory with 

the output files produced by the code developers, which are in the 
\QAFiles\QAoutputforComparison sub-directory. 

a. The files with extension “.pds”, in the two directories contain the peak dose and the 
time of the peak dose for the 16 exposure pathways and for each initially present 
radionuclide for each realization.  

b. The files with extension “.prk” in the two directories contain the peak risk and the time 
of the peak risk for the 16 exposure pathways and for each initially present radionuclide 
for each realization. 

c. The files with extension “.PTG” in the two directories contain the mean, the standard 
deviation and the median of the total dose at each computation time and the total dose 
for the realizations, sorted in descending order at each computation time. There is a file 
for each repetition. 
There is an advantages to comparing the “pds”, “prk” and “PTG” files instead of the 
text report files with extension “.prb” described later.  

i. The doses and risks at each realization can be compared not just the few 
distribution statistics listed in the text reports.  

These files are best compared in a spread sheet. This requires knowledge of how to 
open these fixed width (pds, prk) or space delimited (PTG) ASCII files in your preferred 
spread sheet program. The files may also be compared using file comparison software. 

http://resrad.evs.anl.gov/user-center/


d. The probabilistic text report files, files with extension “.prb”, in the two directories can 
be compared.  

e. The regression analysis text report files, files with extension “.reg” in the two directories 
can also compared.  
These text report files can be compared in a file comparison software or in a word 
processing software. While the probabilistic results are expected to be the same, the 
run time and date which are output on the first few lines of each page will be different. 

f. The deterministic graphics data files with the extension “.grp” in the two directories 
contain the dose, risk and concentrations at each computation time, these are the 
numbers that are used to produce the deterministic and sensitivity graphs in RESRAD-
OFFSITE. These files are best compared in a spread sheet; this requires knowledge of 
how to open these space delimited (or space separated) ASCII files in your preferred 
spread sheet program. The files may also be compared using file comparison software.  
There are advantages to comparing the grp files instead of the text report files 
described later.  

i. There is only a single entry of the date and the time of execution at the 
beginning of the file, not once on every page.  

ii. The dose, risk and concentration can all be compared in a single file.  
iii. These quantities can be compared at each computation time not just the few 

(up to 10) reporting times that were selected in the input file. 
g. The text report files with the extensions “.par” in the two directories contain a listing of 

the input that were used and also a summary of the dose at the up to ten reporting 
times specified in the input file.  
The text report files with the extension “.pro” in the two directories contain the dose at 
the up to ten reporting times specified in the input file. The dose in this case is 
attributed to the radionuclides at the location of exposure, both the initially present and 
the progeny that were produced by radiological transformations. The report with the 
“.par” extension attributes the dose of any transformation products back to the initially 
present parent whose transformations produced the progeny radionuclide.  
The text files with the extension “.rsk” in the two directories contain the excess cancer 
risk at the up to ten reporting times specified in the input file.  
These text report files can be compared in a word processor or in any file comparison 
software. Although the doses, risks and inputs are expected to be the same, the run 
time and date which are output on the first few lines of each page will be different. The 
execution time (or run time) will also likely be different. 

8. The View a deterministic graph and sensitivity graph from this run and compare with the 
corresponding plots for the file in the QAoutputforComparison folder. 

a. Launch the deterministic graphic program from within the main interface using the View 
menu command, and then the Deterministic Graphics submenu command. 

b. Use the New Window menu command under the File Menu of the deterministic 
graphics program to launch a second graphics window. 



c. Use the Open menu command under the File Menu of the deterministic graphics 
program to open the file “COMPREHENSIVE RESRAD-OFFSITE INSTALLATION QA.grp” 
from the “QAoutputforComparison” subdirectory. 

d. Compare the plots in the two windows visually. 
e. Click on one of the inputs in the drop down box below the sensitivity options. 
f. Click on the same input in the dropdown box in the other graphics widow. 
g. Compare the two sensitivity plots visually, then exit the graphics program. 

9. Compare the probabilistic temporal graphics data (dose, risk and concentration) by pathway / 
media and by radionuclide. (Do this only if you intend to investigate the temporal probabilistic 
doses, risks or concentrations by pathway / medium and by radionuclide.) 

a. If the uncertainty/probabilistic interface is not visible, use the Uncertainity/Probabilistic 
Interface submenu command under the View menu command to display it. 

b. Click on the step-by step analysis tab. 
c. Click on the “View temporal plots and statistics of risk and of component doses” 

command button. While the code is generating these data files, it will display a message 
and will launch the deterministic graphics program. 

d. Use the Open menu command under the File Menu of the deterministic graphics 
program to open the file “GRPH461.GRP” from the “QAfiles\QAoutputforComparison\” 
subdirectory. 

e. Use the New Window menu command under the File Menu of the deterministic 
graphics program to launch a second graphics window. 

f. Wait for the code to generate all the files and then use the Open menu command under 
the File Menu of the deterministic graphics program to open the file “GRPH461.GRP” 
from the RESRAD-OFFSITE directory. 

g. Compare the two plots visually. 
h. The 130 files with names beginning with “D” and with extension “.PTG” contain the 

temporal probabilistic dose from each pathway and radionuclide combination indicated 
by the file name for the repletion indicated at the end of the file name. 

i. The 130 files with names beginning with “R” and with extension “.PTG” contain the 
temporal probabilistic risk from each pathway and radionuclide combination indicated 
by the file name for the repletion indicated at the end of the file name. 

j. The 300 files with names beginning with “C” and with extension “.PTG” contain the 
temporal probabilistic concentration of each radionuclide in each medium indicated by 
the file name for the repletion indicated at the end of the file name. 
The \QAFiles\QAoutputforComparison sub-directory contains one file each of these 
three groups of “.PTG” files: DWateC-142.PTG, RWateC-142.PTG, CWeWaC-142.PTG. 
These files can be compared with the corresponding files that you generated. These files 
are best compared in a spread sheet. This requires knowledge of how to open these 
space delimited ASCII files in your preferred spread sheet program. The files may also be 
compared using file comparison software. 

k. Move the files Grph1.grp through Grph500.grp and the 560 files with extension “.PTG” 
from the RESRAD-OFFSITE directory to the QAFiles subdirectory. 


